易语言 - 宝塔面板API签名算法

宝塔 Linux 面板 API 文档

宝塔官方API文档地址:https://bt.cn/api-doc.pdf

签名算法

.版本 2
.支持库 spec

.子程序 宝塔API签名算法
.局部变量 api_sk, 文本型
.局部变量 request_time, 文本型
.局部变量 request_token, 文本型
.局部变量 返回数据, 字节集
.局部变量 返回cookies, 文本型

api_sk = “宝塔面板API接口密钥”
request_time = 时间_到时间戳1 (取现行时间 ())
request_token = 校验_取md5 (到字节集 (request_time + 校验_取md5 (到字节集 (api_sk), , )), , )

返回数据 = 网页_访问_对象 (“http://宝塔IP地址:宝塔端口/system?action=GetSystemTotal”, 1, “request_time=” + request_time + “&request_token=” + request_token, , 返回cookies, , , , , , , , , , , , , , )

返回数据 = 编码_编码转换对象 (返回数据, , , )

调试输出 (request_token, 到文本 (返回数据), 返回cookies)

 

阅读剩余
THE END